{"id":3503662,"name":"github.com/u-root/dhcp4","ecosystem":"go","description":"Package dhcp4 implements constants and marshaling for IPv4 DHCP packets as described by RFC 2131, RFC 2132, and RFC 3396.","homepage":"https://github.com/u-root/dhcp4","licenses":"BSD-3-Clause","normalized_licenses":["BSD-3-Clause"],"repository_url":"https://github.com/u-root/dhcp4","keywords_array":[],"namespace":"github.com/u-root","versions_count":1,"first_release_published_at":"2019-02-06T23:51:19.000Z","latest_release_published_at":"2019-02-06T23:51:19.000Z","latest_release_number":"v0.0.0-20190206235119-03363dc71ec8","last_synced_at":"2026-07-27T07:30:43.277Z","created_at":"2022-04-10T20:25:38.367Z","updated_at":"2026-08-31T15:42:35.932Z","registry_url":"https://pkg.go.dev/github.com/u-root/dhcp4","install_command":"go get github.com/u-root/dhcp4","documentation_url":"https://pkg.go.dev/github.com/u-root/dhcp4#section-documentation","metadata":{},"repo_metadata":{},"repo_metadata_updated_at":"2026-08-31T15:42:35.930Z","dependent_packages_count":0,"downloads":null,"downloads_period":null,"dependent_repos_count":5,"rankings":{"downloads":null,"dependent_repos_count":2.2520481331246605,"dependent_packages_count":9.555658915966655,"stargazers_count":null,"forks_count":null,"docker_downloads_count":null,"average":5.903853524545657},"purl":"pkg:golang/github.com/u-root/dhcp4","advisories":[],"docker_usage_url":"https://docker.ecosyste.ms/usage/go/github.com/u-root/dhcp4","docker_dependents_count":null,"docker_downloads_count":null,"usage_url":"https://repos.ecosyste.ms/usage/go/github.com/u-root/dhcp4","dependent_repositories_url":"https://repos.ecosyste.ms/api/v1/usage/go/github.com/u-root/dhcp4/dependencies","status":null,"funding_links":[],"critical":null,"issue_metadata":null,"versions_url":"https://packages.ecosyste.ms/api/v1/registries/proxy.golang.org/packages/github.com%2Fu-root%2Fdhcp4/versions","version_numbers_url":"https://packages.ecosyste.ms/api/v1/registries/proxy.golang.org/packages/github.com%2Fu-root%2Fdhcp4/version_numbers","latest_version_url":"https://packages.ecosyste.ms/api/v1/registries/proxy.golang.org/packages/github.com%2Fu-root%2Fdhcp4/latest_version","dependent_packages_url":"https://packages.ecosyste.ms/api/v1/registries/proxy.golang.org/packages/github.com%2Fu-root%2Fdhcp4/dependent_packages","related_packages_url":"https://packages.ecosyste.ms/api/v1/registries/proxy.golang.org/packages/github.com%2Fu-root%2Fdhcp4/related_packages","codemeta_url":"https://packages.ecosyste.ms/api/v1/registries/proxy.golang.org/packages/github.com%2Fu-root%2Fdhcp4/codemeta","maintainers":[]}