An open API service providing package, version and dependency metadata of many open source software ecosystems and registries.

npmjs.org "api-governance" keyword

thymian 0.3.0
AI-ready API governance engine - lint, test & analyze HTTP conformance across your entire API lif...
188 versions - Latest release: 27 days ago - 2.29 thousand downloads last month - 34 stars on GitHub - 2 maintainers
@thymian/rules-api-description-validation 0.3.0
Thymian rule set for validating API description documents
187 versions - Latest release: 27 days ago - 3.56 thousand downloads last month - 34 stars on GitHub - 2 maintainers
@thymian/rules-rfc-9110 0.3.0
Thymian rule set implementing RFC 9110 HTTP semantics validation
186 versions - Latest release: 27 days ago - 3.69 thousand downloads last month - 34 stars on GitHub - 2 maintainers
@thymian/core 0.3.0
Core library with the plugin system, rule engine, and HTTP primitives for Thymian
234 versions - Latest release: 27 days ago - 5.11 thousand downloads last month - 34 stars on GitHub - 2 maintainers
@thymian/rules-rfc-6797 0.3.0
Thymian rule set implementing RFC 6797 HTTP Strict Transport Security (HSTS) validation
9 versions - Latest release: 27 days ago - 820 downloads last month - 34 stars on GitHub - 2 maintainers
@thymian/common-cli 0.3.0
Shared CLI utilities, commands, and configuration management for Thymian
186 versions - Latest release: 27 days ago - 3.99 thousand downloads last month - 34 stars on GitHub - 2 maintainers
Top 1.8% on npmjs.org
@redocly/cli 2.73.0
[@Redocly](https://redocly.com) CLI is your all-in-one API documentation utility. It builds, mana...
777 versions - Latest release: 2 days ago - 22 dependent packages - 169 dependent repositories - 10.7 million downloads last month - 1,544 stars on GitHub - 5 maintainers
@camcima/nestjs-deprecation 1.2.0
NestJS library for RFC 9745 (Deprecation) and RFC 8594 (Sunset) HTTP response headers, with Swagg...
5 versions - Latest release: about 2 months ago - 407 downloads last month - 1 stars on GitHub - 1 maintainer
@developerhub/openapi-cli 2.22.2
[@Redocly](https://redocly.com) CLI is your all-in-one API documentation utility. It builds, mana...
6 versions - Latest release: 8 months ago - 68 downloads last month - 1,544 stars on GitHub - 1 maintainer
delimit-cli 4.22.0 💰
Keep the state. Change the model. Shared context and a multi-model panel across Claude Code, Code...
259 versions - Latest release: 24 days ago - 5.37 thousand downloads last month - 23 stars on GitHub - 1 maintainer
@redocly/recheck 2.75.0
Markdown and prose linting engine for Redocly CLI
46 versions - Latest release: about 19 hours ago - 77.4 thousand downloads last month - 1,544 stars on GitHub - 5 maintainers
@developerhub/openapi-core 2.22.2
See https://github.com/Redocly/redocly-cli
6 versions - Latest release: 8 months ago - 68 downloads last month - 1,544 stars on GitHub - 1 maintainer
@redocly/reunite-integration 2.75.0
Programmatic access to the Redocly Reunite platform capabilities
101 versions - Latest release: about 19 hours ago - 9.3 thousand downloads last month - 1,544 stars on GitHub - 5 maintainers
@depup/redocly__openapi-core 2.64.1-depup.0
@redocly/openapi-core with all dependencies updated to latest
63 versions - Latest release: 19 days ago - 3.17 thousand downloads last month - 1,544 stars on GitHub - 1 maintainer
Top 1.3% on npmjs.org
@redocly/openapi-core 2.73.0
See https://github.com/Redocly/redocly-cli
860 versions - Latest release: 2 days ago - 57 dependent packages - 2,272 dependent repositories - 44.7 million downloads last month - 1,544 stars on GitHub - 5 maintainers
@fakeyanss/redocly-cli 1.6.23
[@Redocly](https://redocly.com) CLI is your all-in-one OpenAPI utility. It builds, manages, impro...
24 versions - Latest release: over 2 years ago - 139 downloads last month - 1,544 stars on GitHub - 1 maintainer
@fakeyanss/redocly-openapi-core 1.6.3
See https://github.com/Redocly/redocly-cli
3 versions - Latest release: almost 3 years ago - 37 downloads last month - 1,544 stars on GitHub - 1 maintainer
@developerhub/respect-core 2.22.2
API testing framework core
4 versions - Latest release: 8 months ago - 45 downloads last month - 1,544 stars on GitHub - 1 maintainer
postman-cli 1.85.0
Official Postman CLI - Command-line companion for API development, testing, and automation
102 versions - Latest release: 1 day ago - 1 dependent package - 1 dependent repositories - 115 thousand downloads last month - 6 maintainers
@redocly/respect-core 2.73.0
API testing framework core
661 versions - Latest release: 2 days ago - 3.05 million downloads last month - 1,544 stars on GitHub - 5 maintainers
@redocly/client-generator 0.9.0
Generate typed, zero-dependency TypeScript clients (fetch, auth, retries, middleware, SSE) from O...
182 versions - Latest release: 2 days ago - 30.7 thousand downloads last month - 1,544 stars on GitHub - 5 maintainers
Top 1.6% on npmjs.org
@redocly/openapi-cli 1.0.0-beta.95
OpenAPI CLI toolbox with rich validation and bundling features.
155 versions - Latest release: over 4 years ago - 31 dependent packages - 508 dependent repositories - 183 thousand downloads last month - 1,543 stars on GitHub - 5 maintainers
openlint 1.0.0 💰
- **Custom Rulesets**: Create custom rules to lint JSON or YAML objects - **Ready-to-use Rulesets...
3 versions - Latest release: 13 days ago - 1 dependent package - 1 dependent repositories - 478 downloads last month - 12 stars on GitHub - 1 maintainer
coderifts 8.8.2
Signed, offline-verifiable authorization for API-contract changes. Only a granted change can proc...
71 versions - Latest release: 4 days ago - 3.6 thousand downloads last month - 0 stars on GitHub - 1 maintainer
specshield 3.5.0
Contract compatibility testing for APIs — catch breaking OpenAPI changes before they reach your c...
54 versions - Latest release: 8 days ago - 1.76 thousand downloads last month - 5 stars on GitHub - 1 maintainer
@xata.io/redocly-openapi-cli 1.0.1 removed
OpenAPI CLI toolbox with rich validation and bundling features.
1 version - Latest release: almost 5 years ago - 1 dependent package - 13 downloads last month - 1,537 stars on GitHub - 2 maintainers
@openlint/openlint-formatters 0.1.0 💰
This project exposes the available formatters from the CLI for users that perform custom validati...
5 versions - Latest release: 9 days ago - 12 stars on GitHub - 3 maintainers
@openlint/openlint-ref-resolver 0.1.0 💰
This package provides Spectral-compatible bindings for [@stoplight/json-ref-resolver](https://git...
4 versions - Latest release: 9 days ago - 444 downloads last month - 12 stars on GitHub - 3 maintainers
@openlint/openlint-cli 0.0.0 removed 💰
Placeholder to enable npm trusted publishing
2 versions - Latest release: 13 days ago - 7 stars on GitHub - 3 maintainers
@openlint/openlint-ruleset-migrator 0.1.0 💰
This project serves as a converter between the legacy ruleset format and a new one. It's used int...
4 versions - Latest release: 9 days ago - 12 stars on GitHub - 3 maintainers
@openlint/openlint-rulesets 0.0.1 💰
A flexible JSON/YAML linter for creating automated API style guides, with baked in support for Op...
3 versions - Latest release: 13 days ago - 7 stars on GitHub - 3 maintainers
@openlint/openlint-parsers 1.0.0 💰
A flexible JSON/YAML linter for creating automated API style guides, with baked in support for Op...
4 versions - Latest release: 13 days ago - 7 stars on GitHub - 3 maintainers
@openlint/openlint-functions 0.0.1 💰
A flexible JSON/YAML linter for creating automated API style guides, with baked in support for Op...
3 versions - Latest release: 13 days ago - 7 stars on GitHub - 3 maintainers
@openlint/openlint-core 0.1.0 💰
A flexible JSON/YAML linter for creating automated API style guides, with baked in support for Op...
4 versions - Latest release: 9 days ago - 7 stars on GitHub - 3 maintainers
@openlint/openlint-runtime 0.0.1 💰
A flexible JSON/YAML linter for creating automated API style guides, with baked in support for Op...
3 versions - Latest release: 13 days ago - 7 stars on GitHub - 3 maintainers
@openlint/openlint-formats 0.0.1 💰
A flexible JSON/YAML linter for creating automated API style guides, with baked in support for Op...
3 versions - Latest release: 13 days ago - 471 downloads last month - 7 stars on GitHub - 3 maintainers
@openlint/openlint-ruleset-bundler 0.1.0 💰
- **plugins** - any other Rollup.js plugin, i.e. a minifier. - **target**: - `node` - a preset ...
4 versions - Latest release: 9 days ago - 7 stars on GitHub - 3 maintainers
@jentic/api-scorecard-formatter-html 1.12.0
HTML formatter for Jentic API Scorecard results.
29 versions - Latest release: about 2 months ago - 823 downloads last month - 21 stars on GitHub - 2 maintainers
@jentic/api-scorecard-cli 1.12.0
Score an OpenAPI document against the Jentic API AI Readiness Framework (JAIRF).
59 versions - Latest release: about 2 months ago - 807 downloads last month - 21 stars on GitHub - 2 maintainers
@api-common/spectral-ruleset-studio 0.3.0
Turn a prose style guide into an OWNED, GROUNDED, well-named Spectral ruleset in your browser — p...
3 versions - Latest release: 4 months ago - 1 stars on GitHub - 1 maintainer
@grapity/grapity 0.16.0 💰
Open-source API governance. Ship APIs that won't break your consumers.
21 versions - Latest release: 3 months ago - 80 downloads last month - 3 stars on GitHub - 1 maintainer
@coderifts/contract-path 1.3.1
Path-name classifier for API contract artifacts (OpenAPI, AsyncAPI, GraphQL, gRPC, MCP). Single l...
5 versions - Latest release: 27 days ago - 274 downloads last month - 0 stars on GitHub - 1 maintainer
delimit-presets 1.0.0 💰
Governance policy presets for Delimit — PCI-DSS, HIPAA, fintech, startup, enterprise, and more
1 version - Latest release: 7 months ago - 26 downloads last month - 0 stars on GitHub - 1 maintainer
@useobo/core 0.0.1
OBO Core - Agentic API governance engine
1 version - Latest release: 9 months ago - 0 stars on GitHub - 1 maintainer
@coderifts/backstage-plugin 1.0.0 deprecated
CodeRifts API governance plugin for Backstage — risk scoring, breaking change detection, and PR-l...
1 version - Latest release: 8 months ago - 16 downloads last month - 1 maintainer
@postman/postman-passport 0.5.6
Official Passport CLI - Command-line companion for API development, testing, and automation
12 versions - Latest release: 2 months ago - 1.39 thousand downloads last month - 3 maintainers
x-openapi-flow 1.8.1
Enforce, visualize and generate code from OpenAPI resource lifecycles — runtime guard, SDK gen, P...
34 versions - Latest release: about 2 months ago - 2.13 thousand downloads last month - 5 stars on GitHub - 1 maintainer
@postman/rules-config-changeset 0.0.0-beta.1
This is a npm module which calculates the changeset between the rules config
1 version - Latest release: almost 3 years ago - 76 downloads last month - 3 maintainers
@coderifts/openai-agents 0.1.0
CodeRifts contract governance for the OpenAI Agents SDK — a tool-input guardrail that gates contr...
1 version - Latest release: 2 months ago - 1 maintainer