An open API service providing package, version and dependency metadata of many open source software ecosystems and registries.

npmjs.org "challenge-response" keyword

@golobic/ocra 1.0.0
Zero-dependency RFC 6238 TOTP, RFC 4226 HOTP and RFC 6287 OCRA for Node, Deno, Bun, browsers and ...
1 version - Latest release: about 1 month ago - 382 downloads last month - 0 stars on GitHub - 1 maintainer
sigelo-agent 0.1.9
Agent-side sigelo CLI: create an identity (DID), sign world challenges, collect attestations, bui...
9 versions - Latest release: 1 day ago - 270 downloads last month - 0 stars on GitHub - 1 maintainer
@solidus-network/auth 0.7.1
DID-based authentication and DID-less BBS+ selective-disclosure verification for the Solidus Netw...
12 versions - Latest release: 26 days ago - 352 downloads last month - 0 stars on GitHub - 1 maintainer
@razroo/actionproof 0.2.2
Action-bound, signed proof challenges for verifying fresh autonomous agent work.
4 versions - Latest release: 5 months ago - 2 stars on GitHub - 1 maintainer
@getaid/crypto 1.0.1
Ed25519 keypair generation, challenge-response signing, and HMAC badge URL utilities for getaid.dev
2 versions - Latest release: 7 months ago - 8 downloads last month - 1 maintainer
@xiyewuqiu/shield 0.5.2
πŸ›‘οΈ Shield Guard WASM SDK β€” Rust ηΌ–θ―‘ηš„ι«˜ζ€§θƒ½ API ι˜²ζŠ€οΌˆζŒ‘ζˆ˜ζ±‚θ§£ + 反调试 + ζŒ‡ηΊΉ + 签名)
6 versions - Latest release: 7 months ago - 91 downloads last month - 1 maintainer
crypto-iff-core 0.1.0
Cryptographic challenge-response (IFF) protocol for drone fleet authentication using Ed25519, SHA...
1 version - Latest release: 8 months ago - 0 stars on GitHub - 1 maintainer
avi-verify 2.1.0
AVI Verify CLI - Challenge-response protocol for verifying agent autonomy
2 versions - Latest release: 8 months ago - 1 maintainer
@zerobase-labs/passport-sdk 0.1.1
SDK for Agent Passport β€” OAuth-like identity verification for AI agents
2 versions - Latest release: 8 months ago - 27 downloads last month - 15 stars on GitHub - 1 maintainer
expo-secure-enclave 0.2.0
Hardware-backed ECDSA P-256 signing for Expo and React Native using the iOS Secure Enclave and An...
2 versions - Latest release: 8 days ago - 0 stars on GitHub - 1 maintainer
cit-auth 7.1.0
A cryptographic intent-based authentication library for Node.js and Express that replaces JWTs wi...
2 versions - Latest release: 9 months ago - 27 downloads last month - 0 stars on GitHub - 1 maintainer
@seedkey/sdk-client 0.0.1
SeedKey Auth SDK - client library for passwordless authentication via the SeedKey browser extension
1 version - Latest release: 10 months ago - 12 downloads last month - 0 stars on GitHub - 1 maintainer
webx403-client 1.0.0
WebX403 Client SDK - Seamless HTTP-native Solana wallet authentication for web3 applications
1 version - Latest release: 11 months ago - 5 downloads last month - 4 stars on GitHub - 1 maintainer
@openkitx403/client 0.1.6
TypeScript client SDK for OpenKitx403 wallet authentication
5 versions - Latest release: 11 months ago - 36 downloads last month - 1 stars on GitHub - 1 maintainer
@cap.js/cli 0.0.5 deprecated
CLI server-side solver for the Cap, a lightweight, modern open-source CAPTCHA alternative designe...
5 versions - Latest release: over 1 year ago - 3 downloads last month - 7,922 stars on GitHub - 1 maintainer
genuine-browser 2.2.8
A package to detect browser requests using cryptographic challenge-response mechanism.
19 versions - Latest release: about 2 years ago - 119 downloads last month - 1 maintainer
@claudewerk/mutual-key-auth 0.2.0
Mutual, independently-revocable bearer-key authentication with challenge-response direction proof...
2 versions - Latest release: 23 days ago - 1 maintainer
@eternaljs/captcha 0.1.0
This npm package generates secure and customizable CAPTCHA images for web applications, preventin...
1 version - Latest release: over 2 years ago - 17 downloads last month - 1 maintainer
@vantezzen/pow 1.0.2
A simple challenge-response proof-of-work implementation for web apps
2 versions - Latest release: over 3 years ago - 3 downloads last month - 0 stars on GitHub - 1 maintainer
simple-digest-md5 1.0.4
A simple pure-js implementation of DIGEST-MD5. Written for XMPP, but can be used elsewhere.
5 versions - Latest release: almost 9 years ago - 1 dependent repositories - 30 downloads last month - 1 stars on GitHub - 1 maintainer
capgent-sdk 2.0.0
TypeScript SDK for Capgent β€” agent verification, reverse CAPTCHA challenges, and API identity.
3 versions - Latest release: 7 months ago - 64 downloads last month - 1 maintainer
slip0013 0.0.1
implements SLIP-0013 : Authentication using deterministic hierarchy
1 version - Latest release: over 7 years ago - 1 dependent package - 1 dependent repositories - 9 downloads last month - 0 stars on GitHub - 1 maintainer