An open API service providing package, version and dependency metadata of many open source software ecosystems and registries.

opam.ocaml.org

5,682

Packages

38,214

Versions

smtml 0.31.0
An SMT solver frontend for OCaml
42 versions - Latest release: 4 days ago - 81 stars on GitHub
windtrap 0.2.0
One library for all your OCaml tests
2 versions - Latest release: 7 days ago - 8 stars on GitHub
tinybox 0.3.6
Every game and app of elm-playground in one binary
1 version - Latest release: 1 day ago - 32 stars on GitHub
ocsipersist-pgsql-config 3.1.2
Ocsigen Server configuration file extension for ocsipersist-pgsql
3 versions - Latest release: 8 days ago - 9 stars on GitHub
tiny_libs 0.3.6
From-scratch libraries for teaching: graphics, audio, compression, crypto, networking and more
1 version - Latest release: 1 day ago - 32 stars on GitHub
tiny_appkits 0.3.6
Application engines from scratch: a spreadsheet, rich text, paint, draw, CAD, editors and more
1 version - Latest release: 1 day ago - 32 stars on GitHub
zmq 6.0.0
OCaml bindings for ZeroMQ 4.x
22 versions - Latest release: 2 days ago - 1 stars on GitHub
zmq-async 6.0.0
Async-aware bindings to ZMQ
11 versions - Latest release: 2 days ago - 1 stars on GitHub
checkseum 0.5.4
Adler-32, CRC32 and CRC32-C implementation in C and OCaml
20 versions - Latest release: 2 days ago - 16 stars on GitHub
tiny_languages 0.3.6
Small languages from scratch: Scheme, Lisp, Smalltalk-80, Pascal, BASIC, JavaScript, HTML, CSS an...
1 version - Latest release: 1 day ago - 32 stars on GitHub
tally 0.0.2
Collecting metrics of OCaml applications
2 versions - Latest release: 7 days ago
zmq-eio 6.0.0
Eio aware bindings to ZMQ
2 versions - Latest release: 2 days ago - 1 stars on GitHub
zmq-lwt 6.0.0
Lwt-aware bindings to ZMQ
11 versions - Latest release: 2 days ago - 1 stars on GitHub
shakuhachi 0.4.0
A music collection manager
7 versions - Latest release: 1 day ago
slhdsa 0.2.0 💰
Pure OCaml implementation of FIPS 205 SLH-DSA
2 versions - Latest release: 6 days ago - 0 stars on GitHub
rocq-stdlib 9.2.0
The Rocq Proof Assistant -- Standard Library
3 versions - Latest release: 6 days ago - 42 stars on GitHub
rocq-runtime 9.3.0
The Rocq Prover -- Core Binaries and Tools
6 versions - Latest release: 6 days ago - 5,596 stars on GitHub
rocq-core 9.3.0
The Rocq Prover with its prelude
6 versions - Latest release: 6 days ago - 5,596 stars on GitHub
ffmpeg-av 1.4.0
Bindings for the ffmpeg libraries -- top-level helpers
29 versions - Latest release: 6 days ago - 55 stars on GitHub
rfc1951 1.6.1
Implementation of RFC1951 in OCaml
18 versions - Latest release: 5 days ago - 119 stars on GitHub
tally-mnet 0.0.2
Collecting metrics of Mkernel and emit them on the wire
1 version - Latest release: 7 days ago
rocq-native 3
Package flag enabling rocq's native-compiler flag
3 versions - Latest release: 6 days ago
rocqide 9.3.0
The Rocq Prover --- GTK3 IDE
6 versions - Latest release: 6 days ago - 5,596 stars on GitHub
tally-mkernel 0.0.2
Collecting metrics of Mkernel
2 versions - Latest release: 7 days ago
rake 0.7.0
Vector-first language for predictable SIMD
1 version - Latest release: 1 day ago - 0 stars on GitHub
ppx_hegel_test 0.25.0
PPX expander for Hegel test definitions with Antithesis support
13 versions - Latest release: 4 days ago - 24 stars on GitHub
reeve 0.1.0
SLATEC and a few LAPACK routines in OCaml
1 version - Latest release: 3 days ago - 0 stars on GitHub
mm 0.8.7
The mm library contains high-level APIs to create and manipulate multimedia streams (audio, video...
21 versions - Latest release: 6 days ago - 39 stars on GitHub
ohttp-cohttp-lwt 0.1.2
Oblivious HTTP (RFC 9458) clients, relays, and gateways over cohttp-lwt
1 version - Latest release: 1 day ago - 0 stars on GitHub
ppx_hegel_generator 0.25.0
PPX deriver for Hegel generator derivation
13 versions - Latest release: 4 days ago - 24 stars on GitHub
ppx_hegel_compat 0.25.0
Internal ppxlib AST shim shared by Hegel's PPX packages
13 versions - Latest release: 4 days ago - 24 stars on GitHub
rocq-devtools 9.3.0
Development tools for Rocq
4 versions - Latest release: 6 days ago - 5,596 stars on GitHub
pure-html 4.0.0 💰
HTML generator eDSL
13 versions - Latest release: 7 days ago - 208 stars on GitHub
ocsipersist-sqlite-config 3.1.2
Ocsigen Server configuration file extension for ocsipersist-sqlite
3 versions - Latest release: 8 days ago - 9 stars on GitHub
cvc5 1.3.0-3
OCaml bindings for the cvc5 SMT solver
5 versions - Latest release: 7 days ago - 5 stars on GitHub
ohttp 0.1.2
Oblivious HTTP (RFC 9458) for OCaml
1 version - Latest release: 1 day ago - 0 stars on GitHub
ohttp-piaf 0.1.2
Oblivious HTTP (RFC 9458) clients, relays, and gateways over Piaf
1 version - Latest release: 1 day ago - 0 stars on GitHub
ocsipersist-lib 3.1.2
Persistent key/value storage for OCaml - support library
7 versions - Latest release: 8 days ago - 9 stars on GitHub
miniyaml 0.1.0
A simple YAML parser in pure OCaml
1 version - Latest release: 6 days ago - 0 stars on GitHub
ocsipersist-dbm 3.1.2
Persistent key/value storage for OCaml using DBM
6 versions - Latest release: 8 days ago - 9 stars on GitHub
ppx_windtrap 0.2.0
PPX and instrumentation backend for windtrap
2 versions - Latest release: 7 days ago - 8 stars on GitHub
mlkem 0.2.0 💰
Pure OCaml implementation of FIPS 203 ML-KEM
2 versions - Latest release: 6 days ago - 0 stars on GitHub
ohttp-cohttp 0.1.2
Oblivious HTTP (RFC 9458) for the types of the http package
1 version - Latest release: 1 day ago - 0 stars on GitHub
ohttp-cohttp-eio 0.1.2
Oblivious HTTP (RFC 9458) clients, relays, and gateways over cohttp-eio
1 version - Latest release: 1 day ago - 0 stars on GitHub
ocsipersist-sqlite 3.1.2
Persistent key/value storage for OCaml using SQLite
5 versions - Latest release: 8 days ago - 9 stars on GitHub
mutaml 0.4
A mutation tester for OCaml
4 versions - Latest release: 1 day ago - 75 stars on GitHub
ocsipersist-pgsql 3.1.2
Persistent key/value storage for OCaml using PostgreSQL
10 versions - Latest release: 8 days ago - 9 stars on GitHub
ocsipersist 3.1.2
Persistent key-value storage for OCaml using multiple backends
6 versions - Latest release: 8 days ago - 9 stars on GitHub
mldsa 0.2.0 💰
Pure OCaml implementation of FIPS 204 ML-DSA
2 versions - Latest release: 6 days ago - 0 stars on GitHub
ffmpeg-avdevice 1.4.0
Bindings for the ffmpeg avdevice library
29 versions - Latest release: 6 days ago - 55 stars on GitHub
ffmpeg-avutil 1.4.0
Bindings for the ffmpeg avutil libraries
29 versions - Latest release: 6 days ago - 55 stars on GitHub
httpcats 0.3.3 💰
A simple HTTP client / server using h1, h2, and miou
8 versions - Latest release: 5 days ago - 44 stars on GitHub
ffmpeg-swscale 1.4.0
Bindings for the ffmpeg swscale library
29 versions - Latest release: 6 days ago - 55 stars on GitHub
mdx 2.7.0
Executable code blocks inside markdown files
27 versions - Latest release: 3 days ago - 290 stars on GitHub
mkernel 0.0.5 💰
An unikernel with Miou in OCaml to provide I/O for Solo5
5 versions - Latest release: 5 days ago - 16 stars on GitHub
linol-lwt 0.12
LSP server library (with Lwt for concurrency)
12 versions - Latest release: 6 days ago - 43 stars on GitHub
hpke 0.4.0 💰
Idiomatic RFC 9180 Hybrid Public Key Encryption for OCaml
4 versions - Latest release: 3 days ago - 0 stars on GitHub
linol 0.12
LSP server library
12 versions - Latest release: 6 days ago - 43 stars on GitHub
jack 0.1.0
Bindings for the Jack library which provides functions for linking audio programs
1 version - Latest release: 6 days ago - 0 stars on GitHub
ffmpeg-avcodec 1.4.0
Bindings for the ffmpeg avcodec library
29 versions - Latest release: 6 days ago - 55 stars on GitHub
elm_playground_3d_webgl 0.3.6
Web 3D playground platform on the GPU (WebGL 1)
1 version - Latest release: 1 day ago - 32 stars on GitHub
current_web 0.8.0
Test web UI for OCurrent
17 versions - Latest release: 4 days ago - 158 stars on GitHub
elm_playground_native 0.3.6
Native playground platform: SDL window, Cairo drawing
3 versions - Latest release: 1 day ago - 32 stars on GitHub
ffmpeg-swresample 1.4.0
Bindings for the ffmpeg swresample library
29 versions - Latest release: 6 days ago - 55 stars on GitHub
linol-eio 0.12
LSP server library (with Eio for concurrency)
7 versions - Latest release: 6 days ago - 43 stars on GitHub
hegel 0.25.0
Hegel property-based testing library for OCaml
13 versions - Latest release: 4 days ago - 24 stars on GitHub
elm_playground_web 0.3.6
Web playground platform: js_of_ocaml, vdom and SVG
3 versions - Latest release: 1 day ago - 32 stars on GitHub
elm_playground_gamekits 0.3.6
Genre kits for Playground games: platformers, racing, shoot 'em ups, fighting and more
1 version - Latest release: 1 day ago - 32 stars on GitHub
ffmpeg-avfilter 1.4.0
Bindings for the ffmpeg avfilter library
29 versions - Latest release: 6 days ago - 55 stars on GitHub
current_gitlab 0.8.0
GitLab plugin for OCurrent
12 versions - Latest release: 4 days ago - 158 stars on GitHub
ffmpeg 1.4.0
Bindings for the ffmpeg libraries
39 versions - Latest release: 6 days ago - 55 stars on GitHub
coq 9.3.0
Compatibility metapackage for Coq after the Rocq renaming
58 versions - Latest release: 6 days ago - 5,596 stars on GitHub
elm_playground_3d_web 0.3.6
Web 3D playground platform drawing through SVG
1 version - Latest release: 1 day ago - 32 stars on GitHub
dream-html 4.0.0 💰
HTML generator eDSL for Dream
26 versions - Latest release: 7 days ago - 208 stars on GitHub
decompress 1.6.1
Implementation of Zlib and GZip in OCaml
25 versions - Latest release: 5 days ago - 119 stars on GitHub
current_ssh 0.8.0
SSH plugin for OCurrent
9 versions - Latest release: 4 days ago - 158 stars on GitHub
docfd 13.1.2
TUI multiline fuzzy document finder
11 versions - Latest release: 3 days ago - 289 stars on GitHub
elm_playground_software 0.3.6
Native playground platform with a from-scratch software rasterizer
1 version - Latest release: 1 day ago - 32 stars on GitHub
elm_playground_3d_software 0.3.6
Native 3D playground platform with a from-scratch software rasterizer
1 version - Latest release: 1 day ago - 32 stars on GitHub
elm_playground_3d 0.3.6
Interface of the 3D Playground
1 version - Latest release: 1 day ago - 32 stars on GitHub
elm_playground_3d_opengl 0.3.6
Native 3D playground platform on the GPU (OpenGL 3.3 core)
1 version - Latest release: 1 day ago - 32 stars on GitHub
elm_playground 0.3.6
Interface of the Playground: pictures, animations and games
3 versions - Latest release: 1 day ago - 32 stars on GitHub
current_github 0.8.0
GitHub plugin for OCurrent
17 versions - Latest release: 4 days ago - 158 stars on GitHub
current_slack 0.8.0
Slack plugin for OCurrent
17 versions - Latest release: 4 days ago - 158 stars on GitHub
current_rpc 0.8.0
Cap'n Proto RPC plugin for OCurrent
17 versions - Latest release: 4 days ago - 158 stars on GitHub
current_git 0.8.0
Git plugin for OCurrent
17 versions - Latest release: 4 days ago - 158 stars on GitHub
current_examples 0.8.0
Example pipelines for OCurrent
17 versions - Latest release: 4 days ago - 158 stars on GitHub
coq-core 9.3.0
Compatibility binaries for Coq after the Rocq renaming
14 versions - Latest release: 6 days ago - 5,596 stars on GitHub
catala-lsp 1.3.0
Catala Language Server Protocol (LSP)
6 versions - Latest release: 5 days ago - 4 stars on GitHub
bhttp 0.1.2
Binary Representation of HTTP Messages (RFC 9292) for OCaml
1 version - Latest release: 1 day ago - 0 stars on GitHub
catala 1.3.0
Compiler and library for the literate programming language for tax code specification
15 versions - Latest release: 5 days ago - 2,396 stars on GitHub
current_docker 0.8.0
OCurrent Docker plugin
17 versions - Latest release: 4 days ago - 158 stars on GitHub
coqide-server 9.3.0
The Rocq Prover, XML protocol server
14 versions - Latest release: 6 days ago - 5,596 stars on GitHub
conf-jack 3
Virtual package relying on jack
3 versions - Latest release: 6 days ago
conf-python3-sympy 1
Check that Python 3 can import SymPy
1 version - Latest release: 2 days ago
current 0.8.0
Pipeline language for keeping things up-to-date
17 versions - Latest release: 4 days ago - 158 stars on GitHub
coq-stdlib 9.2.0
Compatibility metapackage for Coq Stdlib library after the Rocq renaming
10 versions - Latest release: 6 days ago - 42 stars on GitHub
catala-format 1.3.0
A formatter for Catala based on the Topiary universal formatting engine
9 versions - Latest release: 5 days ago - 4 stars on GitHub
mariadb 2.2.0
OCaml bindings for MariaDB
22 versions - Latest release: 4 days ago - 58 stars on GitHub
ocaml-protoc-plugin 6.3.0
Plugin for protoc protobuf compiler to generate ocaml definitions from a .proto file
14 versions - Latest release: 7 days ago - 29 stars on GitHub