An open API service providing package, version and dependency metadata of many open source software ecosystems and registries.

packagist.org "uri" keyword

fengyongz-guzzlehttp/psr7 1.6.1
PSR-7 message implementation that also provides common utility methods
16 versions - Latest release: over 7 years ago - 5.44 thousand downloads total - 0 stars on GitHub - 1 maintainer
Top 0.1% on packagist.org
guzzlehttp/psr7 3.2.0 πŸ’°
PSR-7 message implementation that also provides common utility methods
74 versions - Latest release: 12 days ago - 2,658 dependent packages - 357,073 dependent repositories - 1.17 billion downloads total - 7,931 stars on GitHub - 6 maintainers
adamwojs/data-uri 0.3.0
PHP DataURI component
1 version - Latest release: about 1 year ago - 50 downloads total - 0 stars on GitHub - 1 maintainer
effectra/http-extensions v2.2.1
The Effectra HTTP Extensions package.
7 versions - Latest release: almost 3 years ago - 1 dependent package - 1 dependent repositories - 44 downloads total - 0 stars on GitHub - 1 maintainer
Top 1.6% on packagist.org
laminas/laminas-uri 2.14.0 πŸ’°
A component that aids in manipulating and validating Β» Uniform Resource Identifiers (URIs)
78 versions - Latest release: 11 months ago - 83 dependent packages - 1,705 dependent repositories - 42 million downloads total - 38 stars on GitHub - 1 maintainer
Top 1.4% on packagist.org
league/uri-interfaces 7.9.1 πŸ’°
Common tools for parsing and resolving RFC3987/RFC3986 URI
27 versions - Latest release: 3 days ago - 14 dependent packages - 2,981 dependent repositories - 304 million downloads total - 539 stars on GitHub - 2 maintainers
Top 0.1% on packagist.org
symfony/routing v8.1.10 πŸ’°
Maps an HTTP request to a set of configuration variables
697 versions - Latest release: 3 days ago - 1,478 dependent packages - 511,776 dependent repositories - 917 million downloads total - 7,612 stars on GitHub - 1 maintainer
button/button
Fast and lightweight router for PHP
Latest release: about 10 hours ago - 4 dependent repositories - 8 downloads total - 0 stars on GitHub - 1 maintainer
xiaoyu/guzzle-tools 2.2
guzzle tools
8 versions - Latest release: almost 8 years ago - 10 downloads total - 1 stars on GitHub - 1 maintainer
Top 8.0% on packagist.org
crwlr/url v2.2.0
Swiss Army knife for URLs.
22 versions - Latest release: 10 months ago - 2 dependent packages - 2 dependent repositories - 98.1 thousand downloads total - 109 stars on GitHub - 1 maintainer
uri-interop/impl 1.0.0
Reference implementations of Uri-Interop.
4 versions - Latest release: over 1 year ago - 30 downloads total - 0 stars on GitHub - 1 maintainer
Top 0.3% on packagist.org
league/uri 7.9.1 πŸ’°
URI manipulation library
43 versions - Latest release: 3 days ago - 227 dependent packages - 4,449 dependent repositories - 305 million downloads total - 1,131 stars on GitHub - 1 maintainer
Top 2.5% on packagist.org
amphp/uri v0.1.4 πŸ’°
Uri Parser and Resolver.
5 versions - Latest release: over 7 years ago - 23 dependent packages - 91 dependent repositories - 1.96 million downloads total - 23 stars on GitHub - 4 maintainers
balpom/web-link v1.1.1
Advanced interfaces for HTTP links and it's realisation.
3 versions - Latest release: over 2 years ago - 44 downloads total - 0 stars on GitHub - 1 maintainer
Top 7.1% on packagist.org
hautelook/templated-uri-router 4.0.0 πŸ’°
Symfony URL generator that provides an RFC-6570-compatible router.
13 versions - Latest release: almost 4 years ago - 3 dependent packages - 125 dependent repositories - 1.82 million downloads total - 2 stars on GitHub - 2 maintainers
windwalker/uri 4.2.9
Windwalker Uri package
132 versions - Latest release: 5 months ago - 4 dependent packages - 19 dependent repositories - 190 thousand downloads total - 0 stars on GitHub - 1 maintainer
linkuha/uri 1.0beta
Uri validator and fixer
1 version - Latest release: almost 7 years ago - 40 downloads total - 0 stars on GitHub - 1 maintainer
Top 1.1% on packagist.org
pear/net_url2 v2.2.3
Class for parsing and handling URL. Provides parsing of URLs into their constituent parts (scheme...
19 versions - Latest release: over 1 year ago - 33 dependent packages - 297 dependent repositories - 13.8 million downloads total - 49 stars on GitHub - 1 maintainer
xiaodi/think-psr7 v2.7.7
PSR-7 message implementation that also provides common utility methods
19 versions - Latest release: over 5 years ago - 21 downloads total - 0 stars on GitHub - 1 maintainer
Top 1.1% on packagist.org
ringcentral/psr7 1.3.0
PSR-7 message implementation
6 versions - Latest release: over 8 years ago - 72 dependent packages - 2,429 dependent repositories - 22.9 million downloads total - 150 stars on GitHub - 1 maintainer
shineforge/compass 1.0.0
A modern, robust, and PSR-7 compatible URL manipulation library for PHP.
1 version - Latest release: over 1 year ago - 0 downloads total - 0 stars on GitHub - 1 maintainer
league/uri-polyfill 7.9.0 πŸ’°
Polyfill backporting PHP 8.5+ native RFC3986/WHATWG URI features to lower PHP versions
5 versions - Latest release: 13 days ago - 137 thousand downloads total - 1 stars on GitHub - 1 maintainer
karewan/knroute 4.1.0
Simple and fast PHP 8.3+ router with route attributes and caching
23 versions - Latest release: about 1 month ago - 2.62 thousand downloads total - 2 stars on GitHub - 1 maintainer
effectra/http-message v2.0.0
The Effectra HTTP Message package.
5 versions - Latest release: 3 months ago - 5 dependent packages - 1 dependent repositories - 89 downloads total - 0 stars on GitHub - 1 maintainer
Top 6.2% on packagist.org
cybercog/laravel-optimus 3.13.0 πŸ’°
An Optimus bridge for Laravel. Id obfuscation based on Knuth's multiplicative hashing method.
19 versions - Latest release: 6 months ago - 8 dependent repositories - 597 thousand downloads total - 194 stars on GitHub - 1 maintainer
friend-of-pastry-garden/utils-bundle 1.0.8
Fourniture d'outils d'aide au dΓ©veloppement
8 versions - Latest release: almost 3 years ago - 1 dependent package - 303 downloads total - 0 stars on gitlab.adullact.net - 1 maintainer
noxkiwi/rewrite
Latest release: 3 days ago - 1 downloads total - 1 maintainer
myerscode/utilities 2.0.1
A collection of utility classes that make working with things much easier.
4 versions - Latest release: over 4 years ago - 3 downloads total - 2 stars on GitHub - 1 maintainer
Top 6.3% on packagist.org
windwalker/http 4.2.9
Windwalker Http package
123 versions - Latest release: about 1 month ago - 11 dependent packages - 11 dependent repositories - 129 thousand downloads total - 6 stars on GitHub - 1 maintainer
hamlet-framework/http-message 0.0.5
Hamlet Framework / HTTP / Request
4 versions - Latest release: over 5 years ago - 2 dependent packages - 2 dependent repositories - 23 thousand downloads total - 0 stars on GitHub - 1 maintainer
ql/uri-template 1.1.3
An implementation of RFC 6570 level 4
5 versions - Latest release: over 8 years ago - 8 dependent packages - 21 dependent repositories - 880 thousand downloads total - 1 stars on GitHub - 2 maintainers
nguyenanhung/uri-helper v2.0.5 πŸ’°
URI Helper, basic, simple and light
10 versions - Latest release: about 2 years ago - 3 dependent packages - 1 dependent repositories - 26.6 thousand downloads total - 0 stars on GitHub - 1 maintainer
Top 3.2% on packagist.org
joomla/uri 4.0.0 πŸ’°
Joomla Uri Package
20 versions - Latest release: over 1 year ago - 19 dependent packages - 235 dependent repositories - 865 thousand downloads total - 6 stars on GitHub - 3 maintainers
psecio/uri 0.1
A secure URI generation and validation library
1 version - Latest release: over 8 years ago - 12 downloads total - 12 stars on GitHub - 1 maintainer
theprivateer/permalink v0.1.0
Simple utility for creating URL friendly 'slugs'
2 versions - Latest release: about 9 years ago - 9 downloads total - 1 stars on GitHub - 1 maintainer
uri-template/uri-template v1.0.0
RFC 6570 URI Template processor
1 version - Latest release: over 11 years ago - 1 dependent package - 4 dependent repositories - 58.4 thousand downloads total - 7 stars on GitHub - 1 maintainer
bentools/hostname-extractor 1.3
Hostname extractor - A library to find parts of a hostname (suffix, tld, subdomain, ...)
7 versions - Latest release: over 7 years ago - 1 dependent package - 1 dependent repositories - 577 downloads total - 0 stars on GitHub - 1 maintainer
Top 1.8% on packagist.org
league/uri-components 7.9.0 πŸ’°
URI components manipulation library
51 versions - Latest release: 13 days ago - 59 dependent packages - 482 dependent repositories - 60 million downloads total - 318 stars on GitHub - 2 maintainers
georgringer/uri2link 0.2.0 πŸ’°
Convert external url like domain.tld/services to TYPO3 links if this is url is actually served by...
2 versions - Latest release: almost 3 years ago - 1 dependent repositories - 6 thousand downloads total - 4 stars on GitHub - 1 maintainer
agregalel/router-php 1.0.2
fast router for your projects
1 version - Latest release: about 3 years ago - 7 downloads total - 0 stars on GitHub - 1 maintainer
laithshadeed/uri-parser
Sample URI Parser - Not meant to be used in production
Latest release: 4 days ago - 6 downloads total - 0 stars on GitHub - 1 maintainer
xrplwin/xrpl-nfttxmutationparser v1.0.18
Parse XRPL NFT transaction to context aware object providing direction, token id and roles.
22 versions - Latest release: over 1 year ago - 205 downloads total - 1 stars on GitHub - 1 maintainer
irfantoor/http 0.2.1
Psr Compliant HTTP suite for Hackers
3 versions - Latest release: over 5 years ago - 1 dependent package - 1 dependent repositories - 48 downloads total - 0 stars on GitHub - 1 maintainer
Top 5.0% on packagist.org
zf1/zend-uri 1.12.20
Zend Framework 1 Uri package
18 versions - Latest release: over 11 years ago - 22 dependent packages - 108 dependent repositories - 721 thousand downloads total - 2 stars on GitHub - 1 maintainer
zobzn/zbz-uri 0.0.1 abandoned
URI Manipulation
1 version - Latest release: almost 11 years ago - 4 dependent repositories - 128 downloads total - 0 stars on GitHub - 1 maintainer
zf1s/zend-uri 1.16.2
Zend Framework 1 Uri package
28 versions - Latest release: about 2 months ago - 11 dependent packages - 26 dependent repositories - 967 thousand downloads total - 0 stars on GitHub - 1 maintainer
zenstruck/uri v2.4.0 πŸ’°
Object-oriented wrapper/manipulator for parse_url with additional features.
13 versions - Latest release: 11 months ago - 1 dependent package - 3 dependent repositories - 92.2 thousand downloads total - 16 stars on GitHub - 1 maintainer
Top 0.8% on packagist.org
zendframework/zend-uri 2.7.1 abandoned
A component that aids in manipulating and validating Β» Uniform Resource Identifiers (URIs)
66 versions - Latest release: about 7 years ago - 151 dependent packages - 5,884 dependent repositories - 27.6 million downloads total - 114 stars on GitHub - 1 maintainer
zabachok/yii2-onion-url
Url rule class to make github-like urls.
Latest release: 25 days ago - 25 downloads total - 0 stars on GitHub - 1 maintainer
yuubit/uri 1.1.0
PHP Library to deal with uris.
6 versions - Latest release: almost 8 years ago - 1 dependent package - 1 dependent repositories - 352 downloads total - 0 stars on GitHub - 1 maintainer
Top 9.7% on packagist.org
yowcow/mime-base64-urlsafe 0.2.2
PHP-version of URL safe base64 encoding/decoding
9 versions - Latest release: over 9 years ago - 2 dependent packages - 6 dependent repositories - 21.5 thousand downloads total - 6 stars on GitHub - 1 maintainer
yidas/uri 1.1.0
URL Standardized Redirector with Customized Setting for SEO
2 versions - Latest release: almost 9 years ago - 22 downloads total - 0 stars on GitHub - 1 maintainer
xiaoyi510/psr7 1.7.0
PSR-7 message implementation that also provides common utility methods
18 versions - Latest release: about 6 years ago - 1 dependent package - 10 downloads total - 0 stars on GitHub - 1 maintainer
wok/uri v1.2.5
WOK URI handler
8 versions - Latest release: over 9 years ago - 2 dependent packages - 2 dependent repositories - 108 downloads total - 0 stars on GitHub - 1 maintainer
Top 5.5% on packagist.org
vdb/uri v0.3.4
A set of URI classes and a URI parser, based on RFC 3986
11 versions - Latest release: over 1 year ago - 2 dependent packages - 24 dependent repositories - 237 thousand downloads total - 11 stars on GitHub - 1 maintainer
webmaniacs.net/lib-uri 1.0
Represents a Uniform Resource Identifier (URI), Uniform Resource Locator (URL) and File Resource ...
2 versions - Latest release: over 11 years ago - 1 dependent package - 5 dependent repositories - 386 downloads total - 0 stars on GitHub - 1 maintainer
Top 2.7% on packagist.org
webignition/url 2.0.1 abandoned
A PSR-7 UriInterface implementation. A normalizer for applying sixteen lossy and lossless normali...
46 versions - Latest release: over 8 years ago - 15 dependent packages - 27 dependent repositories - 210 thousand downloads total - 32 stars on GitHub - 1 maintainer
voku/purl v3.0.1 abandoned πŸ’°
Purl is a simple Object Oriented URL manipulation library for PHP 5.3+ [Fork]
16 versions - Latest release: over 8 years ago - 5.78 thousand downloads total - 2 stars on GitHub - 1 maintainer
viserio/http abandoned
The Viserio Http package.
Latest release: 6 months ago - 6 dependent repositories - 9.81 thousand downloads total - 0 stars on GitHub - 1 maintainer
userfrosting/uniformresourcelocator 4.5.1 abandoned
Uniform Resource Locator module for UserFrosting
15 versions - Latest release: over 5 years ago - 4 dependent packages - 2 dependent repositories - 41.5 thousand downloads total - 3 stars on GitHub - 1 maintainer
vairogs/twig-helper-uri removed
Twig extension that implements vairogs/utils Uri helper functions in Twig template
Latest release: over 3 years ago
vairogs/twig-helper removed
Twig extension that implements vairogs/utils helper functions in Twig template
Latest release: over 3 years ago
upyx/uri-signature 1.1.0
Sing and verify URIs.
2 versions - Latest release: almost 5 years ago - 2 downloads total - 1 stars on GitHub - 1 maintainer
phpgt/http v2.0.0 πŸ’°
PSR-7 HTTP message implementation.
36 versions - Latest release: 3 months ago - 7 dependent packages - 16 dependent repositories - 23.6 thousand downloads total - 1 stars on GitHub - 1 maintainer
phpgt/routing v1.2.0 πŸ’°
Routes HTTP requests to your code.
19 versions - Latest release: 3 months ago - 2 dependent packages - 8 dependent repositories - 6.04 thousand downloads total - 0 stars on GitHub - 1 maintainer
tkr2f/uri-resolver 2.1.0 abandoned
URI Reference Resolution
5 versions - Latest release: over 6 years ago - 57 downloads total - 2 stars on GitHub - 1 maintainer
tiat/uri 1.5.3 removed
Library for manipulating and validating URIs (Uniform Resource Identifiers). Fully PHP 8.3 compli...
18 versions - Latest release: over 3 years ago - 7 dependent packages - 5 dependent repositories - 70 downloads total - 1 stars on GitLab.com - 1 maintainer
talesoft/tale-uri 0.2.0 abandoned
A basic, lightweight PSR-7 and PSR-17 compatible URI implementation
2 versions - Latest release: almost 8 years ago - 1 dependent repositories - 21 downloads total - 1 stars on GitHub - 1 maintainer
Top 5.9% on packagist.org
sunrise/uri v1.2.5 abandoned
URI wrapper for PHP 7.1+ based on RFC-3986, PSR-7 and PSR-17
34 versions - Latest release: almost 4 years ago - 5 dependent packages - 20 dependent repositories - 87.7 thousand downloads total - 11 stars on GitHub - 1 maintainer
subscribo/psr-http-message-tools v0.4.4
Tools which could be used with PSR-7: Request factory, Uri factory, Response parser
7 versions - Latest release: over 10 years ago - 2 dependent packages - 3 dependent repositories - 472 downloads total - 0 stars on GitHub - 1 maintainer
subapp/uri v1.0.1
URL/URI Library
6 versions - Latest release: over 7 years ago - 2 dependent packages - 2 dependent repositories - 33 downloads total - 0 stars on GitHub - 1 maintainer
stasdovgodko/uri
Represents a Uniform Resource Identifier (URI) reference.
Latest release: 5 days ago - 1 dependent repositories - 263 downloads total - 0 stars on GitHub - 1 maintainer
spomky-labs/uri-util v1.0.2 abandoned
Uri Manipulation Utilities
3 versions - Latest release: almost 11 years ago - 7 dependent packages - 2.66 thousand downloads total - 1 maintainer
selby/urlparser removed
Small and simple url parser library
Latest release: 12 months ago - 1 downloads total - 0 stars on GitHub - 1 maintainer
axy/fs-paths 0.1.1
Manipulation of the file system paths
2 versions - Latest release: almost 11 years ago - 4 dependent repositories - 20 downloads total - 1 stars on GitHub - 1 maintainer
ryanve/slash 3.0.0 πŸ’°
URI and filesystem path utilities.
1 version - Latest release: almost 13 years ago - 5 dependent repositories - 530 downloads total - 16 stars on GitHub - 1 maintainer
runn/http v7.4.0
Runn Me! HTTP Library
3 versions - Latest release: over 6 years ago - 1 dependent repositories - 200 downloads total - 2 stars on GitHub - 1 maintainer
deloz/botium 0.1.0
A light web crawl written in PHP
1 version - Latest release: over 11 years ago - 21 downloads total - 1 stars on GitHub - 1 maintainer
renolit/reint-file-timestamp 5.0.0
Timestamp parameter in public file uri
11 versions - Latest release: 3 months ago - 18.7 thousand downloads total - 3 stars on GitHub - 1 maintainer
reloaded/uri-builder v1.0.0
A URI builder library inspired by Android's Uri.Builder.
1 version - Latest release: over 11 years ago - 20 downloads total - 3 stars on GitHub - 1 maintainer
pls/identifier-uri 0.1.0
PLS URI specification
1 version - Latest release: about 9 years ago - 1 dependent package - 1 dependent repositories - 45 downloads total - 0 stars on GitHub - 1 maintainer
php-rest/uri-templates 1.0.0
A library for matching and expansion for URI templates.
1 version - Latest release: about 10 years ago - 19 downloads total - 0 stars on GitHub - 1 maintainer
opgginc/codezero-laravel-uri-translator 2.0.3 πŸ’°
Translate a URI or individual slugs.
3 versions - Latest release: 7 months ago - 160 thousand downloads total - 0 stars on GitHub - 1 maintainer
Top 5.6% on packagist.org
wa72/url v0.7.1
Class for handling and manipulating URLs
6 versions - Latest release: over 8 years ago - 2 dependent packages - 30 dependent repositories - 253 thousand downloads total - 31 stars on GitHub - 1 maintainer
pfwd/vimeo-api-uri v1.1.0
A PHP Library that holds Vimeo API URI's
3 versions - Latest release: over 7 years ago - 1 dependent package - 1 dependent repositories - 10 downloads total - 1 stars on GitHub - 1 maintainer
opulence/net v1.0.0-alpha9 πŸ’°
The Aphiria network library
11 versions - Latest release: about 3 years ago - 162 downloads total - 3 stars on GitHub - 1 maintainer
Top 4.2% on packagist.org
opis/uri 1.1.0
Build, parse and validate URIs and URI-templates
2 versions - Latest release: over 5 years ago - 4 dependent packages - 87 dependent repositories - 34.5 million downloads total - 23 stars on GitHub - 2 maintainers
Top 8.9% on packagist.org
opale/externalurigenerator 0.8.0
PSR-7 compatible library to build Uris that go outside of your application
8 versions - Latest release: over 11 years ago - 1 dependent package - 4 dependent repositories - 20.8 thousand downloads total - 1 maintainer
opale/externaluribundle 1.1.3
Build Uri that goes outside of your symfony application
5 versions - Latest release: almost 11 years ago - 4 dependent repositories - 20.6 thousand downloads total - 1 maintainer
october/router v1.0.419 abandoned
Basic URL Router
101 versions - Latest release: almost 10 years ago - 1 dependent package - 4 dependent repositories - 664 downloads total - 1 maintainer
net_bazzline/php_component_apache_server_status_parser 0.3.1 abandoned
php component to ease up reading and processing the apache server status (mod_status)
6 versions - Latest release: almost 9 years ago - 921 downloads total - 5 stars on GitHub - 1 maintainer
myerscode/utilities-web 2026.0.0
A fluent interface for interacting with web page content and urls.
7 versions - Latest release: 7 months ago - 1 dependent package - 1 dependent repositories - 72 downloads total - 2 stars on GitHub - 1 maintainer
modularr/uri 1.0.0
Single Responisibilty Uri Library
1 version - Latest release: about 6 years ago - 42 downloads total - 3 stars on GitHub - 1 maintainer
Top 3.1% on packagist.org
ml/iri 1.1.4
IRI handling for PHP
6 versions - Latest release: almost 13 years ago - 7 dependent packages - 192 dependent repositories - 7.75 million downloads total - 26 stars on GitHub - 1 maintainer
bentools/url 1.0.1
Url object representation
4 versions - Latest release: almost 11 years ago - 1 dependent package - 4 dependent repositories - 1.05 thousand downloads total - 0 stars on GitHub - 1 maintainer
vitnasinec/uri v1.0.2
Adds/removes/updates query string of current request uri
3 versions - Latest release: almost 2 years ago - 116 downloads total - 0 stars on GitHub - 1 maintainer
ginsen/uri v1.0.2
Psr\Http\Message\UriInterface value object for calls to internal containers
3 versions - Latest release: over 1 year ago - 2 downloads total - 0 stars on GitHub - 1 maintainer
limbo/http 0.1.1 removed
HTTP implementation for PSR-7 and PSR-17.
1 version - Latest release: over 5 years ago - 2 downloads total
Top 5.0% on packagist.org
league/uri-query-parser 1.0.1 abandoned
parse and build a query string the right way in PHP
2 versions - Latest release: over 7 years ago - 9 dependent packages - 5 dependent repositories - 379 thousand downloads total - 37 stars on GitHub - 2 maintainers
larvatatw/psr7 1.6.1
PSR-7 message implementation that also provides common utility methods
16 versions - Latest release: over 7 years ago - 1.92 thousand downloads total - 0 stars on GitHub - 1 maintainer