Ecosyste.ms: Packages

An open API service providing package, version and dependency metadata many open source software ecosystems and registries.

pub.dev packages

Loading...
Top 1.3% on pub.dev
qr_flutter 4.0.0
QR.Flutter is a Flutter library for simple and fast QR code rendering via a Widget or custom pain...
14 versions - Latest release: almost 2 years ago - 55 dependent packages - 1,366 dependent repositories - 605 stars on GitHub
Top 1.1% on pub.dev
graphql_flutter 5.1.2
A GraphQL client for Flutter, bringing all the features from a modern GraphQL client to one easy ...
126 versions - Latest release: 26 days ago - 24 dependent packages - 431 dependent repositories
Top 0.9% on pub.dev
graphql 5.1.3
A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to ...
102 versions - Latest release: 26 days ago - 38 dependent packages - 565 dependent repositories
Top 1.8% on pub.dev
floor 1.4.1
The typesafe, reactive, and lightweight SQLite abstraction for your Flutter applications. This li...
31 versions - Latest release: about 2 months ago - 9 dependent packages - 253 dependent repositories
Top 1.8% on pub.dev
floor_generator 1.4.1
The typesafe, reactive, and lightweight SQLite abstraction for your Flutter applications. This li...
31 versions - Latest release: about 2 months ago - 9 dependent packages - 251 dependent repositories
Top 1.0% on pub.dev
flutter_hooks 0.18.5+1 💰
A flutter implementation of React hooks. It adds a new kind of widget with enhanced code reuse.
45 versions - Latest release: 8 months ago - 153 dependent packages - 1,837 dependent repositories - 2,488 stars on GitHub
Top 1.6% on pub.dev
better_player 0.0.83
Advanced video player based on video_player and Chewie. It's solves many typical use cases and it...
84 versions - Latest release: 8 months ago - 20 dependent packages - 179 dependent repositories - 704 stars on GitHub
Top 0.8% on pub.dev
fl_chart 0.60.0 💰
A highly customizable Flutter chart library that supports Line Chart, Bar Chart, Pie Chart, Scatt...
84 versions - Latest release: 12 days ago - 25 dependent packages - 1,658 dependent repositories - 5,048 stars on GitHub
idenfy_sdk_flutter 2.0.8
iDenfy SDK for Flutter. iDenfy - all-in-one identity verification and fraud prevention platform h...
28 versions - Latest release: 6 days ago - 2 stars on GitHub
omniversify_core 0.0.8
The Foundation of the the Omniversify Project, this package started as a way for the Omniversify ...
8 versions - Latest release: about 2 months ago - 1 dependent repositories - 0 stars on GitHub
Top 6.3% on pub.dev
flutter_map_location_marker 5.2.0+1
A flutter map plugin for displaying device current location.
36 versions - Latest release: 10 days ago - 3 dependent packages - 38 dependent repositories - 39 stars on GitHub
dartactyl 1.6.10-dev.2
An API client wrapper for Pterodactyl Panel. Following V1 for now.
85 versions - Latest release: 8 days ago - 4 stars on GitHub
dart_autotrader 1.1.0
An Autotrader API library for dart and flutter developers
2 versions - Latest release: 29 days ago
Top 1.9% on pub.dev
wechat_assets_picker 8.4.0 💰
An image picker (also with videos and audio) for Flutter projects based on WeChat's UI, with full...
142 versions - Latest release: about 3 hours ago - 17 dependent packages - 64 dependent repositories - 1,075 stars on GitHub
filter_word 1.1.1
A package that allow you to filter word as a string. Change to asterisk, sensor, or remove word f...
3 versions - Latest release: about 2 months ago
fastlane_screenshot_automation 0.1.0
Helper to setup fastlane on both android and ios projects
10 versions - Latest release: about 1 month ago
zerker 2.2.1
Zerker is a flexible and lightweight flutter canvas graphic animation library.
12 versions - Latest release: 4 days ago - 2 dependent repositories - 513 stars on GitHub
Top 1.3% on pub.dev
sass 1.58.0
A Sass implementation in Dart.
236 versions - Latest release: 6 days ago - 24 dependent packages - 178 dependent repositories - 3,297 stars on GitHub
Top 5.6% on pub.dev
sass_api 5.0.0
Additional APIs for Dart Sass.
64 versions - Latest release: 6 days ago - 2 dependent packages - 4 dependent repositories - 3,297 stars on GitHub
Top 1.4% on pub.dev
drift 2.5.0
Drift is a reactive library to store relational data in Dart and Flutter applications.
22 versions - Latest release: 9 days ago - 21 dependent packages - 337 dependent repositories - 1,742 stars on GitHub
Top 1.4% on pub.dev
drift_dev 2.5.1 💰
Dev-dependency for users of drift. Contains the generator and development tools.
30 versions - Latest release: 6 days ago - 17 dependent packages - 300 dependent repositories - 1,836 stars on GitHub
org_flutter 2.1.0
Flutter widgets for displaying Emacs Org Mode (https://orgmode.org) content
32 versions - Latest release: 23 days ago - 3 dependent repositories - 8 stars on GitHub
Top 3.1% on pub.dev
window_manager 0.3.0
This plugin allows Flutter desktop apps to resizing and repositioning the window.
26 versions - Latest release: 29 days ago - 9 dependent packages - 221 dependent repositories - 266 stars on GitHub
Top 2.7% on pub.dev
parse_server_sdk 3.1.12 💰
Dart plugin for Parse Server, (https://parseplatform.org), (https://back4app.com)
49 versions - Latest release: 6 days ago - 5 dependent packages - 93 dependent repositories - 510 stars on GitHub
Top 3.6% on pub.dev
parse_server_sdk_flutter 3.1.3 💰
Flutter plugin for Parse Server, (https://parseplatform.org), (https://back4app.com)
9 versions - Latest release: 7 months ago - 2 dependent packages - 68 dependent repositories - 510 stars on GitHub
applovin_max 2.3.3
AppLovin MAX Flutter Plugin for Android and iOS - with support for interstitial ads, rewarded ads...
16 versions - Latest release: 25 days ago - 1 dependent package - 6 dependent repositories - 26 stars on GitHub
flutter_joystick 0.0.3
A virtual joystick for Flutter applications. Highly flexible and customizable.
3 versions - Latest release: about 2 months ago - 1 dependent package - 15 dependent repositories - 6 stars on GitHub
Top 1.4% on pub.dev
protobuf 2.1.0
Runtime library for protocol buffers support. Use https://pub.dev/packages/protoc_plugin to gener...
85 versions - Latest release: 8 months ago - 286 dependent packages - 1,817 dependent repositories - 423 stars on GitHub
Top 1.3% on pub.dev
mockito 5.3.2
A mock framework inspired by Mockito with APIs for Fakes, Mocks, behavior verification, and stubb...
66 versions - Latest release: 5 months ago - 1,431 dependent packages - 4,063 dependent repositories - 541 stars on GitHub
healthrian_common_support 1.0.15
Healthrian common support library
16 versions - Latest release: about 4 hours ago - 5 dependent packages
loglytics 0.12.0+8
An efficient, user-friendly way to implement logs, analytics and crash reports into your projects.
65 versions - Latest release: about 2 hours ago - 2 dependent repositories - 0 stars on GitHub
image_size_getter_heic 1.0.1
A decoder for HEIC images with image_size_getter.
2 versions - Latest release: about 5 hours ago - 46 stars on GitHub
hainong_expert_module 0.0.3+3
2Nong Expert.
20 versions - Latest release: about 1 month ago
healthrian_ble_support_for_wearcardiot 1.0.12+1
Healthrian BLE support library for WearCardioT
15 versions - Latest release: about 4 hours ago - 2 dependent packages
flutter_multiple_webview_plugin 1.0.6
Plugin that allow Flutter to communicate with a multiple native Webviews.
3 versions - Latest release: about 5 hours ago
healthrian_ble_support_for_cardioclick 1.0.8
Healthrian BLE support library for CardioClick
10 versions - Latest release: about 5 hours ago - 1 dependent package
fluetooth 0.0.6
Flutter library for sending bytes to Bluetooth devices.
6 versions - Latest release: about 2 hours ago - 1 dependent repositories - 1 stars on GitHub
zego_uikit_prebuilt_video_conference 2.0.0
PrebuiltVideoConference is a full-featured Video Conference kit that provides a ready-made group ...
15 versions - Latest release: about 4 hours ago - 1 stars on GitHub
Top 8.1% on pub.dev
tencent_trtc_cloud 2.4.2
With TRTC, you can quickly develop cost-effective, low-latency, and high-quality interactive audi...
106 versions - Latest release: 29 days ago - 3 dependent packages - 5 dependent repositories - 60 stars on GitHub
tengits_common 0.0.47
A UI Flutter package for tengits.
20 versions - Latest release: 39 minutes ago
zego_uikit_signaling_plugin 2.0.0
ZegoUIKitSignalingPlugin is a low-code plugin collection that provides the signal related functio...
16 versions - Latest release: about 4 hours ago - 1 dependent package - 2 dependent repositories
zego_uikit_prebuilt_live_audio_room 2.0.0
PrebuiltLiveAudioRoom is a Live Audio Room kit that provides a ready-made group voice chat that s...
10 versions - Latest release: about 4 hours ago
zego_zimkit 0.9.8-prerelease
zego imkit.
1 version - Latest release: about 4 hours ago
zego_uikit_prebuilt_live_streaming 2.0.0
PrebuiltLiveStreaming is a full-featured live streaming kit that provides ready-made video stream...
33 versions - Latest release: about 4 hours ago - 1 stars on GitHub
zego_uikit_prebuilt_call 2.0.0
PrebuiltCall is a full-featured call kit that provides a ready-made call invitation, voice/video ...
34 versions - Latest release: about 4 hours ago - 1 dependent package - 3 dependent repositories - 1 stars on GitHub
Top 6.6% on pub.dev
zego_uikit 2.0.0
ZegoUIKit is a low-code offering with pre-built and UI-ready components, such as AudioVideoView, ...
33 versions - Latest release: about 4 hours ago - 6 dependent packages
talkjs_flutter 0.7.0
Official TalkJS SDK for Flutter
10 versions - Latest release: about 2 hours ago - 1 dependent repositories
zego_plugin_adapter 2.0.0
ZegoCloud's plugin adapter.
2 versions - Latest release: about 4 hours ago
tinkoff_id_web 1.0.1
Tinkoff Id WebToApp Flutter Realization
2 versions - Latest release: about 3 hours ago
val_api 0.0.3
This package provides an easy way to use the Valorant api in Dart language.
3 versions - Latest release: about 2 hours ago - 0 stars on GitHub
universally 2.2.0
It depends on universally plug and can update the latest available version in time
78 versions - Latest release: about 1 hour ago - 0 stars on GitHub
tflite_web 0.1.1
Run Tensorflow Lite models using TFLite JS and WebAssembly on browser
4 versions - Latest release: about 5 hours ago - 0 stars on GitHub
tinkoff_id_flutter 1.0.1
Tinkoff ID Native Android And iOS Flutter Realization
2 versions - Latest release: about 3 hours ago
p24_sdk 1.0.51
Przelewy24 Mobile Payments SDK integration Flutter integration for iOS and Android
50 versions - Latest release: about 1 hour ago - 1 dependent repositories - 6 stars on GitHub
switchpay 0.0.2
A Flutter plugin that provides Switchpay.
2 versions - Latest release: about 4 hours ago
swipeable_button_flutter 0.0.3
Create attractive swipeable button view in flutter using few simple steps. Very attractive and ve...
3 versions - Latest release: about 5 hours ago - 0 stars on GitHub
simple_accordion 0.1.3
Accordion widget
9 versions - Latest release: about 2 hours ago
rad_html_vscode 0.1.2
Visual-JSX Ready HTML widgets for using in your Rad applications
3 versions - Latest release: about 1 hour ago - 72 stars on GitHub
rec_api_dart 1.4.0-alpha.23
Dart/Fluter implementation of the REC Barcelona API. You can carry out any operation and put the ...
52 versions - Latest release: about 2 hours ago
native_image_cropper_ios 0.1.0
This is the iOS implementation of the native_image_cropper plugin.
1 version - Latest release: about 3 hours ago - 1 stars on GitHub
simple_shared_preferences 1.2.0
A simple wrapper for [SharedPreferences] that supports string, int, double, bool, List<String>, a...
5 versions - Latest release: about 2 hours ago
notification_dispatcher 0.3.2
Inspired by Apple's NotificationCenter. Passes information around to registered observers.
7 versions - Latest release: about 2 hours ago - 1 dependent package - 0 stars on GitHub
quakerbirdad 0.0.4
Flutter信天翁广告插件
4 versions - Latest release: about 2 hours ago - 1 stars on GitHub
native_image_cropper_android 0.1.0
This is the Android implementation of the native_image_cropper plugin.
1 version - Latest release: about 3 hours ago - 1 stars on GitHub
shoplive_player 1.3.1+1
To use Shoplive, please contact [email protected]
12 versions - Latest release: 4 days ago - 1 dependent repositories - 0 stars on GitHub
native_image_cropper_platform_interface 0.1.0
A common platform interface for the native_image_cropper plugin.
1 version - Latest release: about 3 hours ago - 1 stars on GitHub
native_image_cropper 0.1.1
A Flutter plugin for cropping images. Supports rectangular and circular cropping.
2 versions - Latest release: about 2 hours ago - 1 stars on GitHub
postgres_crdt 0.0.7
Dart implementation of Conflict-free Replicated Data Types (CRDTs) using PostgreSQL
2 versions - Latest release: 1 day ago
marqueer 1.2.1
Transform to "Marquee" from any widget.
13 versions - Latest release: about 3 hours ago
mpc_dart 0.3.1
Safeamtrix mpc dart package, ecdsa, eddsa and bls supported.
14 versions - Latest release: about 4 hours ago - 1 dependent package - 1 dependent repositories
Top 8.7% on pub.dev
lucide_icons 0.112.0
A Lucide icon library package for Flutter applications. Fork of Feather Icons, open for anyone to...
134 versions - Latest release: about 3 hours ago - 5 dependent repositories - 2,569 stars on GitHub
material_loading_buttons 1.1.0
Simple loadable button implemented based on flutter material design buttons.
2 versions - Latest release: about 5 hours ago
lol_api 0.0.9
This package provides an easy way to use the League of Legends api in Dart language.
9 versions - Latest release: about 2 hours ago - 1 stars on GitHub
Top 1.9% on pub.dev
flutter_gen_runner 5.2.0 💰
The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.
36 versions - Latest release: about 2 hours ago - 11 dependent packages - 320 dependent repositories - 1,109 stars on GitHub
flutter_conscent_plugin 0.3.3
This is a step by step guide for managing Conscent Plugin and its related subclasses.
32 versions - Latest release: about 2 hours ago
library_architecture_mvvm_modify 0.0.4 💰
MVVM Modify for Dart but you can also port to another language
4 versions - Latest release: about 1 hour ago - 0 stars on GitHub
Top 2.9% on pub.dev
flutter_gen 5.2.0 💰
The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.
65 versions - Latest release: about 2 hours ago - 4 dependent packages - 77 dependent repositories - 1,109 stars on GitHub
healthrian_visualization_support 1.0.17
Healthrian visualization support library
50 versions - Latest release: about 4 hours ago
flutter_webrtc_haoxin 0.9.20+1
Flutter WebRTC plugin for iOS/Android/Destkop/Web, based on GoogleWebRTC.
23 versions - Latest release: about 4 hours ago
focus_detector_v2 3.0.0
Detects when your widget appears or disappears from the screen.
3 versions - Latest release: about 8 hours ago - 0 stars on GitHub
healthrian_ble_support 1.0.12
Healthrian BLE support library
11 versions - Latest release: about 4 hours ago - 1 dependent package
Top 3.2% on pub.dev
flutter_gen_core 5.2.0 💰
The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.
39 versions - Latest release: about 2 hours ago - 2 dependent packages - 306 dependent repositories - 1,109 stars on GitHub
healthrian_ble_support_for_wearecg12 1.0.12+1
Healthrian BLE support library for WearECG12
26 versions - Latest release: about 4 hours ago - 2 dependent packages
fl_assets_picker 0.7.1
fl_assets_picker is used to take photos of the device assets selection and camera and record videos
10 versions - Latest release: about 1 hour ago - 1 dependent repositories - 0 stars on GitHub
easy_chat_game 1.0.0
To implement a scripted chat game for fun
1 version - Latest release: about 1 hour ago
fl_mlkit_scanning 4.0.1
Google mlkit scanning for flutter plugin , supports Android and IOS.
18 versions - Latest release: 2 days ago - 1 dependent repositories - 8 stars on GitHub
app_bar_with_search_switch 2.0.0-dev.5
An extension for AppBar witch can switch it into search field.
22 versions - Latest release: about 2 hours ago - 2 dependent repositories - 3 stars on GitHub
eticon_api 2.0.4
This package will help you quickly and easily work with HTTP REQUESTS. All you need to do is sele...
43 versions - Latest release: about 4 hours ago - 1 dependent package - 2 dependent repositories - 1 stars on GitHub
dio_cookie_caching_handler 0.0.1
An Dio interceptor stores cookies and put in every request.
1 version - Latest release: about 5 hours ago
Top 0.5% on pub.dev
bloc_test 9.1.1 💰
A testing library which makes it easy to test blocs. Built to be used with the bloc state managem...
62 versions - Latest release: about 5 hours ago - 61 dependent packages - 1,463 dependent repositories - 9,726 stars on GitHub
codenic_logger 2.0.3
A logger extension for providing structured and mutable log messages.
31 versions - Latest release: about 2 hours ago - 1 dependent package - 1 dependent repositories - 0 stars on GitHub
eagle_provider 3.0.0
A new Flutter package to simple manager state.Based on Cubit/Provider this package makes use of V...
9 versions - Latest release: about 2 hours ago
build_badge 0.0.3
Badge to distinguish different builds. Such as staging, dev, production etc
2 versions - Latest release: about 5 hours ago
exchange 0.0.4
Provides a set of standardized APIs for exchanges and trading markets.
4 versions - Latest release: about 3 hours ago - 0 stars on GitHub
codenic_exception_converter 1.0.3
A utility tool for converting Exception into Failure objects to make your code more portable and ...
12 versions - Latest release: about 2 hours ago
codenic_bloc_use_case 3.0.3
A suite of abstract cubits to reduce boilerplate code and construct app use cases.
22 versions - Latest release: about 2 hours ago - 0 stars on GitHub
array 0.0.2
用于flutter使用的数组拓展方法 (List extension function)
2 versions - Latest release: about 2 hours ago
Top 8.3% on pub.dev
apptive_grid_core 0.14.5
Core Library for ApptiveGrid used to provide general ApptiveGrid functionality to other Packages ...
65 versions - Latest release: about 2 hours ago - 4 dependent packages - 1 dependent repositories
algo360pfm 0.1.0
Algo360 SDK extracts transactional SMS from the user’s device and provides an expense tracking da...
10 versions - Latest release: about 4 hours ago
Top 1.6% on pub.dev
agora_rtc_engine 6.1.0
Flutter plugin of Agora RTC SDK, allow you to simply integrate Agora Video Calling or Live Video ...
86 versions - Latest release: about 2 months ago - 17 dependent packages - 298 dependent repositories - 629 stars on GitHub